Solusi Mikrotik Hotspot Tanpa Userman 2

Warning
Karena banyaknya kawan-kawan yang gagal menggunakan script ini, saya sarankan kawan-kawan membaca sampai habis jangan setengah-setengah. Script yang saya bikin ini di input di On-Login User Profile Hotspot, bukan di System Script.

Hi,
Melanjutkan postingan saya yang dahulu, kali ini saya akan share beberapa alternatif lain script untuk memudahkan kawan-kawan membuat voucher dengan masa aktif tanpa userman. Ada beberapa script yang dikembangkan oleh master Agung Cespun diantaranya yaitu:

Syarat Berjalannya Script ini

  • Cookies aktif dan Login By Cookie aktif

Script dengan kuota waktu dan masa aktif (Time Based)

Dengan script ini user yang kita buat otomatis akan diberikan Limit-Uptime ketika user tersebut login untuk pertama kalinya. Lalu dengan fitur masa aktif kita bisa tentukan berapa lama user tersebut diberikan masa aktif sesuai keinginan. Dan juga di script ini sudah di atur untuk langsung menghapus user tersebut ketika masa aktifnya sudah habis.

{
:local pengguna $user;
:if ([/ip hotspot user find name=$pengguna limit-uptime=1h]="") do={
/ip hotspot user set [find name=$pengguna] limit-uptime=1h
/ip hotspot active remove [find user=$pengguna]
};
:if ([/system schedule find name=$pengguna]="") do={
/system schedule add name=$pengguna interval=1d on-event="/ip hotspot user remove [find name=$pengguna]\r\n/ip hotspot active remove [find user=$pengguna]\r\n/system schedule remove [find name=$pengguna]"
}
}

script di atas untuk kuota waktu 1 jam(1h) dengan masa aktif 1 hari (1d). Apabila kawan-kawan ingin mengubah nilainya silahkan diisi di bagian limit-uptime dan interval. Untuk Scriptnya sendiri silahkan di paste ke On-Login User Profiles Hotspot

Script Dengan kuota data dan masa aktif (Volume Based)

Dengan menggunakan script ini user yang kita buat otomatis akan diberikan Limit-Bytes-Total ketika user tersebut login untuk pertama kalinya. Jadi seperti paket data operator seluler, kita memberikan berapa total data yang diberikan kepada user.

{
:local pengguna $user;
:if ([/ip hotspot user find name=$pengguna limit-bytes-total=1073741824]="") do={
/ip hotspot user set [find name=$pengguna] limit-bytes-total=1073741824};
/ip hotspot active remove [find user=$pengguna]
};
:if ([/system schedule find name=$pengguna]="") do={
/system schedule add name=$pengguna interval=1d on-event="/ip hotspot user remove [find name=$pengguna]\r\n/ip hotspot active remove [find user=$pengguna]\r\n/system schedule remove [find name=$pengguna]"
}
}

script di atas adalah contoh untuk volume data sebesar 1GB. Perhitungannya adalah mengunakan satuan Bytes. Silahkan kawan-kawan edit sesuai keinginan dan jangan lupa sett masa aktif pada pilihan interval.

Semoga Bermanfaat

15
Leave a Reply

avatar
8 Comment threads
7 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
9 Comment authors
alicia-network.comMadinArifin NoviyadiKhairaniisbernendi Recent comment authors
Madin
Guest

Ijin bertanya gan.
Bisa gx supaya user masih ada tanpa harus di kil. Soalnya kalau masa aktipnya habis user langsung ke hapus. Bagai mana cara ngeidtnya gan supaya user tetap ada. Mohon penjelasanya

Arifin Noviyadi
Guest
Arifin Noviyadi

om ini script untuk 1user saja atau untuk semua user yang terdaftar di Users Hotspot?

Khairani
Guest

kok tidak berfungsi gan

isbernendi
Guest
isbernendi

ngga bisa didownload bos

Si Sue
Guest
Si Sue

Kalau routernya kerestart/shutdown, apa hitungan limit byte nya itu bakalan kereset sendiri atau tersimpan om?

danny
Guest
danny

trus kalo ngga di loout dulu inetnya tetap jalan tu gan

danny
Guest
danny

gan kenapa ya di tampilan user aktive ga muncul time limet sama bite limitny
ngga realtime gitu penggunaanya

Ares
Guest
Ares

Izin om pakai scrip nya